Back to overview
Resolved

Webmail.blamdom.com service interruption

Jul 13, 2026 at 7:29pm UTC  –  Jul 13, 2026 at 9:53pm UTC
Affected services
webmail.blamdom.com

Resolved
Jul 13, 2026 at 9:53pm UTC

Maintenance ended

Updated
Jul 13, 2026 at 9:53pm UTC

Everything migrated, main blamdom services did not go down - everything live migrated

Created
Jul 13, 2026 at 7:29pm UTC

Our main webmail server is undergoing physical issues.
To prevent any sort of service interruptions, we are migrating to our joan.blamdom.com server/NS.

(Service may show down but all emails/websites will be functional)